CVE-2017-5885

NameCVE-2017-5885
DescriptionMultiple integer overflows in the (1) vnc_connection_server_message and (2) vnc_color_map_set functions in gtk-vnc before 0.7.0 allow remote servers to cause a denial of service (crash) or possibly execute arbitrary code via vectors involving SetColorMapEntries, which triggers a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-831-1
NVD severityhigh (attack range: remote)
Debian Bugs854450

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gtk-vnc (PTS)wheezy0.5.0-3.1vulnerable
wheezy (security)0.5.0-3.1+deb7u1fixed
jessie0.5.3-1.3vulnerable
buster, sid, stretch0.6.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gtk-vncsource(unstable)0.6.0-3high854450
gtk-vncsourcewheezy0.5.0-3.1+deb7u1highDLA-831-1

Notes

[jessie] - gtk-vnc <no-dsa> (Minor issue)
http://openwall.com/lists/oss-security/2017/02/05/5

Search for package or bug name: Reporting problems