CVE-2017-5953

NameCVE-2017-5953
Descriptionvim before patch 8.0.0322 does not properly validate values for tree length when handling a spell file, which may result in an integer overflow at a memory allocation site and a resultant buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-822-1, DSA-3786-1
NVD severityhigh (attack range: remote)
Debian Bugs854969

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
neovim (PTS)stretch0.1.7-4fixed
buster, sid0.2.2-1fixed
vim (PTS)wheezy2:7.3.547-7vulnerable
wheezy (security)2:7.3.547-7+deb7u4fixed
jessie2:7.4.488-7+deb8u3fixed
jessie (security)2:7.4.488-7+deb8u2fixed
stretch2:8.0.0197-4+deb9u1fixed
buster, sid2:8.0.1257-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
neovimsource(unstable)0.1.7-4high
vimsource(unstable)2:8.0.0197-2high854969
vimsourcejessie2:7.4.488-7+deb8u2highDSA-3786-1
vimsourcewheezy2:7.3.547-7+deb7u2highDLA-822-1

Notes

Fixed by https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d

Search for package or bug name: Reporting problems