CVE-2017-6302

NameCVE-2017-6302
DescriptionAn issue was discovered in ytnef before 1.9.1. This is related to a patch described as "5 of 9. Integer Overflow."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-878-1, DSA-3846-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libytnef (PTS)stretch1.9.2-2fixed
buster1.9.3-1fixed
bullseye, sid1.9.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libytnefsourcewheezy1.5-4+deb7u1DLA-878-1
libytnefsourcejessie1.5-6+deb8u1DSA-3846-1
libytnefsource(unstable)1.9.1-1

Notes

https://www.x41-dsec.de/lab/advisories/x41-2017-002-ytnef/
https://www.openwall.com/lists/oss-security/2017/02/15/4
fixed in https://github.com/Yeraze/ytnef/commit/b36d6b25b7a546fc28d6c3812124e487987a4910

Search for package or bug name: Reporting problems