CVE-2017-6414

NameCVE-2017-6414
DescriptionMemory leak in the vcard_apdu_new function in card_7816.c in libcacard before 2.5.3 allows local guest OS users to cause a denial of service (host memory consumption) via vectors related to allocating a new APDU object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs856501

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcacard (PTS)stretch1:2.5.0-3fixed
buster1:2.5.3-1fixed
sid1:2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcacardsource(unstable)1:2.5.0-3medium856501

Notes

Fixed by: https://cgit.freedesktop.org/spice/libcacard/commit/?id=9113dc6a303604a2d9812ac70c17d076ef11886c

Search for package or bug name: Reporting problems