CVE-2017-6886

NameCVE-2017-6886
DescriptionAn error within the "parse_tiff_ifd()" function (internal/dcraw_common.cpp) in LibRaw versions before 0.18.2 can be exploited to corrupt memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1057-1, DSA-3950-1
NVD severityhigh (attack range: remote)
Debian Bugs864183

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)wheezy0.14.6-2+deb7u1vulnerable
wheezy (security)0.14.6-2+deb7u3fixed
jessie0.16.0-9+deb8u2vulnerable
jessie (security)0.16.0-9+deb8u3fixed
stretch0.17.2-6vulnerable
stretch (security)0.17.2-6+deb9u1fixed
buster, sid0.18.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.2-2high864183
librawsourcejessie0.16.0-9+deb8u3highDSA-3950-1
librawsourcestretch0.17.2-6+deb9u1highDSA-3950-1
librawsourcewheezy0.14.6-2+deb7u2highDLA-1057-1

Notes

https://github.com/LibRaw/LibRaw/commit/d7c3d2cb460be10a3ea7b32e9443a83c243b2251

Search for package or bug name: Reporting problems