CVE-2017-7191

NameCVE-2017-7191
DescriptionThe netjoin processing in Irssi 1.x before 1.0.2 allows attackers to cause a denial of service (use-after-free) and possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs857502

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)stretch (security), stretch1.0.7-1~deb9u1fixed
buster1.2.0-2+deb10u1fixed
bookworm, sid, bullseye1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcewheezy(not affected)
irssisourcejessie(not affected)
irssisource(unstable)1.0.2-1857502

Notes

[jessie] - irssi <not-affected> (Different code path caused the netjoins to be flushed prior reaching use-after-free condition)
[wheezy] - irssi <not-affected> (Different code path caused the netjoins to be flushed prior reaching use-after-free condition)
https://irssi.org/security/irssi_sa_2017_03.txt
https://github.com/irssi/irssi/commit/77b2631c78461965bc9a7414aae206b5c514e1b3

Search for package or bug name: Reporting problems