CVE-2017-7507

NameCVE-2017-7507
DescriptionGnuTLS version 3.5.12 and earlier is vulnerable to a NULL pointer dereference while decoding a status response TLS extension with valid contents. This could lead to a crash of the GnuTLS server application.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3884-1
NVD severitymedium
Debian Bugs864560

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)stretch3.5.8-5+deb9u5fixed
stretch (security)3.5.8-5+deb9u1fixed
buster3.6.7-4+deb10u5fixed
buster (security)3.6.7-4+deb10u4fixed
bullseye, sid3.6.14-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26sourcewheezy(not affected)
gnutls26source(unstable)(unfixed)
gnutls28sourceexperimental3.5.13-1
gnutls28sourcejessie3.3.8-6+deb8u6DSA-3884-1
gnutls28sourcestretch3.5.8-5+deb9u1DSA-3884-1
gnutls28source(unstable)3.5.8-6864560

Notes

[wheezy] - gnutls26 <not-affected> (Vulnerable code not present)
https://gnutls.org/security.html#GNUTLS-SA-2017-4
https://gitlab.com/gnutls/gnutls/commit/4c4d35264fada08b6536425c051fb8e0b05ee86b
https://gitlab.com/gnutls/gnutls/commit/3efb6c5fd0e3822ec11879d5bcbea0e8d322cd03
https://gitlab.com/gnutls/gnutls/commit/e1d6c59a7b0392fb3b8b75035614084a53e2c8c9

Search for package or bug name: Reporting problems