CVE-2017-7508

NameCVE-2017-7508
DescriptionOpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service when receiving malformed IPv6 packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3900-1
NVD severitymedium (attack range: remote)
Debian Bugs865480

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)wheezy2.2.1-8+deb7u3fixed
wheezy (security)2.2.1-8+deb7u5fixed
jessie (security), jessie2.3.4-5+deb8u2fixed
stretch2.4.0-6+deb9u2fixed
stretch (security)2.4.0-6+deb9u1fixed
buster, sid2.4.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)2.4.3-1medium865480
openvpnsourcejessie2.3.4-5+deb8u2mediumDSA-3900-1
openvpnsourcestretch2.4.0-6+deb9u1mediumDSA-3900-1
openvpnsourcewheezy(not affected)

Notes

[wheezy] - openvpn <not-affected> (Vulnerable code not present)
http://www.openwall.com/lists/oss-security/2017/06/21/6
https://community.openvpn.net/openvpn/wiki/VulnerabilitiesFixedInOpenVPN243
Fixed by (master): https://github.com/OpenVPN/openvpn/commit/c3f47077a7756de5929094569421a95aa66f2022
Fixed by (2.4.x): https://github.com/OpenVPN/openvpn/commit/ed28cde3d8bf3f1459b2f42f0e27d64801009f92
Fixed by (2.3.x): https://github.com/OpenVPN/openvpn/commit/fc61d1bda112ffc669dbde961fab19f60b3c7439

Search for package or bug name: Reporting problems