CVE-2017-7520

NameCVE-2017-7520
DescriptionOpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service and/or possibly sensitive memory leak triggered by man-in-the-middle attacker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-999-1, DSA-3900-1
NVD severitymedium (attack range: remote)
Debian Bugs865480

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)wheezy2.2.1-8+deb7u3vulnerable
wheezy (security)2.2.1-8+deb7u5fixed
jessie (security), jessie2.3.4-5+deb8u2fixed
stretch2.4.0-6+deb9u2fixed
stretch (security)2.4.0-6+deb9u1fixed
buster, sid2.4.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)2.4.3-1medium865480
openvpnsourcejessie2.3.4-5+deb8u2mediumDSA-3900-1
openvpnsourcestretch2.4.0-6+deb9u1mediumDSA-3900-1
openvpnsourcewheezy2.2.1-8+deb7u5mediumDLA-999-1

Notes

Fixed by (master): https://github.com/OpenVPN/openvpn/commit/7718c8984f04b507c1885f363970e2124e3c6c77
Fixed by (2.4.x): https://github.com/OpenVPN/openvpn/commit/043fe327878eba75efa13794c9845f85c3c629f2
Fixed by (2.3.x): https://github.com/OpenVPN/openvpn/commit/f38a4a105979b87ebebe9be1c3d323116d3fb924
https://community.openvpn.net/openvpn/wiki/VulnerabilitiesFixedInOpenVPN243
http://www.openwall.com/lists/oss-security/2017/06/21/6

Search for package or bug name: Reporting problems