CVE-2017-7824

NameCVE-2017-7824
DescriptionA buffer overflow occurs when drawing and validating elements with the ANGLE graphics library, used for WebGL content. This is due to an incorrect value being passed within the library during checks and results in a potentially exploitable crash. This vulnerability affects Firefox < 56, Firefox ESR < 52.4, and Thunderbird < 52.4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1118-1, DLA-1153-1, DSA-3987-1, DSA-4014-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid60.0.2-2fixed
firefox-esr (PTS)jessie (security), jessie52.8.1esr-1~deb8u1fixed
stretch52.6.0esr-1~deb9u1fixed
stretch (security)52.8.1esr-1~deb9u1fixed
buster, sid52.8.1esr-2fixed
thunderbird (PTS)jessie (security), jessie1:52.8.0-1~deb8u1fixed
stretch1:52.6.0-1~deb9u1fixed
stretch (security)1:52.8.0-1~deb9u1fixed
buster, sid1:52.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)56.0-1
firefox-esrsource(unstable)52.4.0esr-2
firefox-esrsourcejessie52.4.0esr-1~deb8u1DSA-3987-1
firefox-esrsourcestretch52.4.0esr-1~deb9u1DSA-3987-1
firefox-esrsourcewheezy52.4.0esr-2~deb7u1DLA-1118-1
thunderbirdsource(unstable)1:52.4.0-1
thunderbirdsourcejessie1:52.4.0-1~deb8u1DSA-4014-1
thunderbirdsourcestretch1:52.4.0-1~deb9u1DSA-4014-1
thunderbirdsourcewheezy1:52.4.0-1~deb7u1DLA-1153-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-21/#CVE-2017-7824
https://www.mozilla.org/en-US/security/advisories/mfsa2017-22/#CVE-2017-7824
https://www.mozilla.org/en-US/security/advisories/mfsa2017-23/#CVE-2017-7824

Search for package or bug name: Reporting problems