CVE-2017-7870

NameCVE-2017-7870
DescriptionLibreOffice before 2017-01-02 has an out-of-bounds write caused by a heap-based buffer overflow related to the tools::Polygon::Insert function in tools/source/generic/poly.cxx.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-910-1, DSA-3837-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)wheezy1:3.5.4+dfsg2-0+deb7u6vulnerable
wheezy (security)1:3.5.4+dfsg2-0+deb7u9fixed
jessie (security), jessie1:4.3.3-2+deb8u7fixed
stretch1:5.2.7-1fixed
buster, sid1:5.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:5.2.5-1high
libreofficesourcejessie1:4.3.3-2+deb8u7highDSA-3837-1
libreofficesourcewheezy1:3.5.4+dfsg2-0+deb7u9highDLA-910-1

Notes

Fixed by: https://github.com/LibreOffice/core/commit/62a97e6a561ce65e88d4c537a1b82c336f012722

Search for package or bug name: Reporting problems