CVE-2017-8364

NameCVE-2017-8364
DescriptionThe read_buf function in stream.c in rzip 2.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-955-1
NVD severitymedium (attack range: remote)
Debian Bugs861614

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rzip (PTS)jessie2.1-2vulnerable
bullseye, sid, buster, stretch2.1-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rzipsource(unstable)2.1-4.1medium861614
rzipsourcewheezy2.1-1+deb7u1mediumDLA-955-1

Notes

[jessie] - rzip <no-dsa> (Minor issue)
https://blogs.gentoo.org/ago/2017/04/29/rzip-heap-based-buffer-overflow-in-read_buf-stream-c/
Patch in http://download.opensuse.org/repositories/openSUSE:/Leap:/42.2:/Update/standard/src/rzip-2.1-151.3.1.src.rpm

Search for package or bug name: Reporting problems