CVE-2017-8399

NameCVE-2017-8399
DescriptionPCRE2 before 10.30 has an out-of-bounds write caused by a stack-based buffer overflow in pcre2_match.c, related to a "pattern with very many captures."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre2 (PTS)stretch10.22-3fixed
buster10.32-5fixed
bullseye10.36-2fixed
bookworm, sid10.40-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre2source(unstable)(not affected)

Notes

- pcre2 <not-affected> (Did only affect revision after r670 upstream; not in a released version)
Fixed by: https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=783
https://vcs.pcre.org/pcre2?view=revision&revision=674

Search for package or bug name: Reporting problems