CVE-2017-8923

NameCVE-2017-8923
DescriptionThe zend_string_extend function in Zend/zend_string.h in PHP through 7.1.5 does not prevent changes to string objects that result in a negative length, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact by leveraging a script's use of .= with a long string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.19-1vulnerable
buster, sid7.0.22-3vulnerable
php7.1 (PTS)buster, sid7.1.8-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0source(unstable)(unfixed)high
php7.1source(unstable)(unfixed)high

Notes

PHP Bug: https://bugs.php.net/bug.php?id=74577
(Duplicate of) PHP Bug: https://bugs.php.net/bug.php?id=73122

Search for package or bug name: Reporting problems