CVE-2017-9120

NameCVE-2017-9120
DescriptionPHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.39+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.30-0+deb9u1vulnerable
stretch (security)7.0.33-0+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(not affected)
php7.0source(unstable)(unfixed)unimportant
php7.1source(unstable)(unfixed)unimportant
php7.2source(unstable)(unfixed)unimportant

Notes

- php5 <not-affected> (Not reproducible, vulnerable code not present.)
PHP Bug: https://bugs.php.net/bug.php?id=74544
Not treated as a security issue by upstream

Search for package or bug name: Reporting problems