CVE-2017-9259

NameCVE-2017-9259
DescriptionThe TDStretch::acceptNewOverlapLength function in source/SoundTouch/TDStretch.cpp in SoundTouch 1.9.2 allows remote attackers to cause a denial of service (memory allocation error and application crash) via a crafted wav file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870856

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
soundtouch (PTS)wheezy1.6.0-3vulnerable
jessie1.8.0-1vulnerable
buster, sid, stretch1.9.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soundtouchsource(unstable)(unfixed)low870856

Notes

[stretch] - soundtouch <no-dsa> (Minor issue)
[jessie] - soundtouch <no-dsa> (Minor issue)
[wheezy] - soundtouch <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems