CVE-2017-9260

NameCVE-2017-9260
DescriptionThe TDStretchSSE::calcCrossCorr function in source/SoundTouch/sse_optimized.cpp in SoundTouch 1.9.2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted wav file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870857

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
soundtouch (PTS)jessie1.8.0-1vulnerable
stretch1.9.2-2+deb9u1fixed
buster, sid1.9.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soundtouchsource(unstable)1.9.2-3low870857
soundtouchsourcestretch1.9.2-2+deb9u1medium

Notes

[jessie] - soundtouch <no-dsa> (Minor issue)
[wheezy] - soundtouch <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems