CVE-2017-9372

NameCVE-2017-9372
DescriptionPJSIP, as used in Asterisk Open Source 13.x before 13.15.1 and 14.x before 14.4.1, Certified Asterisk 13.13 before 13.13-cert4, and other products, allows remote attackers to cause a denial of service (buffer overflow and application crash) via a SIP packet with a crafted CSeq header in conjunction with a Via header that lacks a branch parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3933-1
NVD severitymedium (attack range: remote)
Debian Bugs863901

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pjproject (PTS)jessie2.1.0.0.ast20130823-1vulnerable
jessie (security)2.1.0.0.ast20130823-1+deb8u1fixed
stretch2.5.5~dfsg-6fixed
buster, sid2.7.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pjprojectsource(unstable)2.5.5~dfsg-6medium863901
pjprojectsourcejessie2.1.0.0.ast20130823-1+deb8u1mediumDSA-3933-1

Notes

http://downloads.asterisk.org/pub/security/AST-2017-002.txt

Search for package or bug name: Reporting problems