CVE-2017-9469

NameCVE-2017-9469
DescriptionIn Irssi before 1.0.3, when receiving certain incorrectly quoted DCC files, it tries to find the terminating quote one byte before the allocated memory. Thus, remote attackers might be able to cause a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3885-1
NVD severitymedium (attack range: remote)
Debian Bugs864400

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)wheezy0.8.15-5vulnerable
wheezy (security)0.8.15-5+deb7u1vulnerable
jessie0.8.17-1+deb8u3vulnerable
jessie (security)0.8.17-1+deb8u4fixed
stretch1.0.2-1vulnerable
stretch (security)1.0.2-1+deb9u1fixed
buster, sid1.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.0.3-1medium864400
irssisourcejessie0.8.17-1+deb8u4mediumDSA-3885-1
irssisourcestretch1.0.2-1+deb9u1mediumDSA-3885-1

Notes

https://github.com/irssi/irssi/commit/30a92754bb650c3dedd507d41110443142899a65
https://irssi.org/security/irssi_sa_2017_06.txt

Search for package or bug name: Reporting problems