CVE-2017-9775

NameCVE-2017-9775
DescriptionStack buffer overflow in GfxState.cc in pdftocairo in Poppler before 0.56 allows remote attackers to cause a denial of service (application crash) via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1074-1
NVD severitymedium (attack range: remote)
Debian Bugs865680

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6vulnerable
wheezy (security)0.18.4-6+deb7u4fixed
jessie (security), jessie0.26.5-2+deb8u1vulnerable
stretch0.48.0-2vulnerable
buster, sid0.57.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.57.0-2medium865680
popplersourcewheezy0.18.4-6+deb7u2mediumDLA-1074-1

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=101540
Fixed by: https://cgit.freedesktop.org/poppler/poppler/commit/?id=8f4ff8243a3d599ff2a6c08b1da389e606ba4fc9

Search for package or bug name: Reporting problems