CVE-2018-0493

NameCVE-2018-0493
Descriptionremctld in remctl before 3.14, when an attacker is authorized to execute a command that uses the sudo option, has a use-after-free that leads to a daemon crash, memory corruption, or arbitrary command execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4159-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
remctl (PTS)jessie3.9-1fixed
stretch (security), stretch3.13-1+deb9u1fixed
bullseye, sid, buster3.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
remctlsource(unstable)3.14-1
remctlsourcejessie(not affected)
remctlsourcestretch3.13-1+deb9u1DSA-4159-1
remctlsourcewheezy(not affected)

Notes

[jessie] - remctl <not-affected> (Affected code introduced in 3.12)
[wheezy] - remctl <not-affected> (Affected code introduced in 3.12)
https://www.eyrie.org/~eagle/software/remctl/security/2018-04-01.html
https://git.eyrie.org/?p=kerberos/remctl.git;a=commitdiff;h=e2b34e086f199b39f8ea36dd621684003835d172

Search for package or bug name: Reporting problems