CVE-2018-0497

NameCVE-2018-0497
DescriptionARM mbed TLS before 2.12.0, before 2.7.5, and before 2.1.14 allows remote attackers to achieve partial plaintext recovery (for a CBC based ciphersuite) via a timing-based side-channel attack. This vulnerability exists because of an incorrect fix (with a wrong SHA-384 calculation) for CVE-2013-0169.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1518-1, DSA-4296-1
NVD severitymedium (attack range: remote)
Debian Bugs904821

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u3fixed
buster2.13.0-3fixed
sid2.14.1-2fixed
polarssl (PTS)jessie1.3.9-2.1+deb8u3vulnerable
jessie (security)1.3.9-2.1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)2.12.0-1medium904821
mbedtlssourcestretch2.4.2-1+deb9u3mediumDSA-4296-1
polarsslsource(unstable)(unfixed)medium
polarsslsourcejessie1.3.9-2.1+deb8u4mediumDLA-1518-1

Notes

https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-02

Search for package or bug name: Reporting problems