CVE-2018-0499

NameCVE-2018-0499
DescriptionA cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs902886

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xapian-core (PTS)jessie1.2.19-1+deb8u1fixed
stretch1.4.3-2+deb9u1fixed
buster, sid1.4.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xapian-coresource(unstable)1.4.6-1902886
xapian-coresourcejessie(not affected)
xapian-coresourcestretch1.4.3-2+deb9u1

Notes

[jessie] - xapian-core <not-affected> (vulnerable code not present)
https://lists.xapian.org/pipermail/xapian-discuss/2018-July/009652.html

Search for package or bug name: Reporting problems