CVE-2018-0502

NameCVE-2018-0502
DescriptionAn issue was discovered in zsh before 5.6. The beginning of a #! script file was mishandled, potentially leading to an execve call to a program named on the second line.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2470-1
NVD severityhigh
Debian Bugs908000

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)stretch5.3.1-4vulnerable
stretch (security)5.3.1-4+deb9u4fixed
buster5.7.1-1fixed
bullseye5.8-6fixed
bookworm, sid5.8-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsourcestretch5.3.1-4+deb9u1DLA-2470-1
zshsource(unstable)5.6-1908000

Notes

[jessie] - zsh <no-dsa> (Minor issue)
https://www.zsh.org/mla/zsh-announce/136
https://sourceforge.net/p/zsh/code/ci/1c4c7b6a4d17294df028322b70c53803a402233d

Search for package or bug name: Reporting problems