CVE-2018-1000021

NameCVE-2018-1000021
DescriptionGIT version 2.15.1 and earlier contains a Input Validation Error vulnerability in Client that can result in problems including messing up terminal configuration to RCE. This attack appear to be exploitable via The user must interact with a malicious git server, (or have their traffic modified in a MITM attack).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs889680

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)jessie1:2.1.4-2.1+deb8u6vulnerable
jessie (security)1:2.1.4-2.1+deb8u7vulnerable
stretch (security), stretch1:2.11.0-3+deb9u4vulnerable
buster1:2.19.2-1vulnerable
sid1:2.20.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)(unfixed)unimportant889680

Notes

http://www.batterystapl.es/2018/01/security-implications-of-ansi-escape.html
Terminal emulators need to perform proper escaping

Search for package or bug name: Reporting problems