CVE-2018-1000098

NameCVE-2018-1000098
DescriptionTeluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4170-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pjproject (PTS)jessie (security), jessie2.1.0.0.ast20130823-1+deb8u1vulnerable
stretch2.5.5~dfsg-6vulnerable
stretch (security)2.5.5~dfsg-6+deb9u1fixed
buster, sid2.7.2~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pjprojectsource(unstable)2.7.2~dfsg-1medium
pjprojectsourcestretch2.5.5~dfsg-6+deb9u1mediumDSA-4170-1

Notes

[jessie] - pjproject <ignored> (Minor issue)
http://downloads.asterisk.org/pub/security/AST-2018-002.html
https://trac.pjsip.org/repos/ticket/2093
In jessie Asterisk doesn't use pjproject for SIP (only for ICE, STUN and TURN)

Search for package or bug name: Reporting problems