CVE-2018-1000120

NameCVE-2018-1000120
DescriptionA buffer overflow exists in curl 7.12.3 to and including curl 7.58.0 in the FTP URL handling that allows an attacker to cause a denial of service or worse.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1309-1, DSA-4136-1
NVD severityhigh (attack range: remote)
Debian Bugs893546

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11fixed
jessie (security)7.38.0-4+deb8u16fixed
stretch (security), stretch7.52.1-5+deb9u9fixed
buster7.64.0-4fixed
bullseye7.65.3-1fixed
sid7.66.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.60.0-1high893546
curlsourcejessie7.38.0-4+deb8u10highDSA-4136-1
curlsourcestretch7.52.1-5+deb9u5highDSA-4136-1
curlsourcewheezy7.26.0-1+wheezy25highDLA-1309-1

Notes

https://curl.haxx.se/docs/adv_2018-9cd6.html
https://curl.haxx.se/CVE-2018-1000120.patch

Search for package or bug name: Reporting problems