CVE-2018-1000121

NameCVE-2018-1000121
DescriptionA NULL pointer dereference exists in curl 7.21.0 to and including curl 7.58.0 in the LDAP code that allows an attacker to cause a denial of service
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1309-1, DSA-4136-1
Debian Bugs893546

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)buster7.64.0-4+deb10u2fixed
buster (security)7.64.0-4+deb10u8fixed
bullseye (security), bullseye7.74.0-1.3+deb11u11fixed
bookworm, bookworm (security)7.88.1-10+deb12u5fixed
trixie8.5.0-2fixed
sid8.6.0-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy25DLA-1309-1
curlsourcejessie7.38.0-4+deb8u10DSA-4136-1
curlsourcestretch7.52.1-5+deb9u5DSA-4136-1
curlsource(unstable)7.60.0-1893546

Notes

https://curl.haxx.se/docs/adv_2018-97a2.html
https://curl.haxx.se/CVE-2018-1000121.patch

Search for package or bug name: Reporting problems