CVE-2018-1000122

NameCVE-2018-1000122
DescriptionA buffer over-read exists in curl 7.20.0 to and including curl 7.58.0 in the RTSP+RTP handling code that allows an attacker to cause a denial of service or information leakage
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1309-1, DSA-4136-1
NVD severitymedium (attack range: remote)
Debian Bugs893546

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11fixed
jessie (security)7.38.0-4+deb8u14fixed
stretch (security), stretch7.52.1-5+deb9u9fixed
buster, sid7.64.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.60.0-1medium893546
curlsourcejessie7.38.0-4+deb8u10mediumDSA-4136-1
curlsourcestretch7.52.1-5+deb9u5mediumDSA-4136-1
curlsourcewheezy7.26.0-1+wheezy25mediumDLA-1309-1

Notes

https://curl.haxx.se/docs/adv_2018-b047.html
https://curl.haxx.se/CVE-2018-1000122.patch

Search for package or bug name: Reporting problems