CVE-2018-1000127

NameCVE-2018-1000127
Descriptionmemcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1329-1, DSA-4218-1
NVD severitymedium (attack range: remote)
Debian Bugs894404

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
memcached (PTS)jessie (security), jessie1.4.21-1.1+deb8u2fixed
stretch1.4.33-1vulnerable
stretch (security)1.4.33-1+deb9u1fixed
buster, sid1.5.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
memcachedsource(unstable)1.5.0-1medium894404
memcachedsourcejessie1.4.21-1.1+deb8u2mediumDSA-4218-1
memcachedsourcestretch1.4.33-1+deb9u1mediumDSA-4218-1
memcachedsourcewheezy1.4.13-0.2+deb7u4mediumDLA-1329-1

Notes

https://github.com/memcached/memcached/commit/a8c4a82787b8b6c256d61bd5c42fb7f92d1bae00
https://github.com/memcached/memcached/issues/271

Search for package or bug name: Reporting problems