CVE-2018-1000223

NameCVE-2018-1000223
Descriptionsoundtouch version up to and including 2.0.0 contains a Buffer Overflow vulnerability in SoundStretch/WavFile.cpp:WavInFile::readHeaderBlock() that can result in arbitrary code execution. This attack appear to be exploitable via victim must open maliocius file in soundstretch utility.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs905491

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
soundtouch (PTS)jessie1.8.0-1+deb8u1vulnerable
stretch1.9.2-2+deb9u1vulnerable
buster, sid2.0.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soundtouchsource(unstable)(unfixed)medium905491

Notes

[stretch] - soundtouch <no-dsa> (Minor issue)
[jessie] - soundtouch <no-dsa> (Minor issue)
https://gitlab.com/soundtouch/soundtouch/issues/6

Search for package or bug name: Reporting problems