CVE-2018-1000544

NameCVE-2018-1000544
Descriptionrubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be exploitable via If a site allows uploading of .zip files , an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem..
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1467-1
NVD severityhigh (attack range: remote)
Debian Bugs902720

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-zip (PTS)jessie1.1.6-1+deb8u1vulnerable
jessie (security)1.1.6-1+deb8u2fixed
stretch1.2.0-1.1vulnerable
buster, sid1.2.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-zipsource(unstable)1.2.1-1.1high902720
ruby-zipsourcejessie1.1.6-1+deb8u2highDLA-1467-1

Notes

https://github.com/rubyzip/rubyzip/issues/369
https://github.com/rubyzip/rubyzip/pull/376

Search for package or bug name: Reporting problems