CVE-2018-1000546

NameCVE-2018-1000546
DescriptionTriplea version <= 1.9.0.0.10291 contains a XML External Entity (XXE) vulnerability in Importing game data that can result in Possible information disclosure, server-side request forgery, or remote code execution. This attack appear to be exploitable via Specially crafted game data file (XML).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs902719

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
triplea (PTS)jessie1.7.0.3+dfsg-1vulnerable
stretch1.8.0.9+dfsg-1vulnerable
sid1.9.0.0.7062-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tripleasource(unstable)(unfixed)low902719

Notes

[stretch] - triplea <no-dsa> (Minor issue)
[jessie] - triplea <no-dsa> (Minor issue)
https://0dd.zone/2018/05/31/TripleA-XXE/
https://github.com/triplea-game/triplea/issues/3442

Search for package or bug name: Reporting problems