CVE-2018-1000637

NameCVE-2018-1000637
Descriptionzutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1505-1
NVD severitymedium (attack range: remote)
Debian Bugs902936, 904819

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zutils (PTS)jessie1.3-4vulnerable
jessie (security)1.3-4+deb8u1fixed
stretch1.5-5+deb9u1fixed
buster, sid1.7-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zutilssource(unstable)1.7-3medium902936, 904819
zutilssourcejessie1.3-4+deb8u1mediumDLA-1505-1
zutilssourcestretch1.5-5+deb9u1medium

Notes

http://www.openwall.com/lists/oss-security/2018/08/05/1
https://lists.nongnu.org/archive/html/zutils-bug/2018-08/msg00000.html
Fixed by: upstream/0001-zcat-buffer-overrun.patch (in 1.7-3)

Search for package or bug name: Reporting problems