CVE-2018-1000838

NameCVE-2018-1000838
Descriptionautopsy version <= 4.9.0 contains a XML External Entity (XXE) vulnerability in CaseMetadata XML Parser that can result in Disclosure of confidential data, denial of service, SSRF, port scanning. This attack appear to be exploitable via Specially crafted CaseMetadata.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
autopsy (PTS)jessie2.24-1fixed
stretch2.24-2fixed
bullseye, sid, buster2.24-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
autopsysource(unstable)(not affected)

Notes

- autopsy <not-affected> (The ancient version in Debian predates the Java rewrite)

Search for package or bug name: Reporting problems