CVE-2018-1002209

NameCVE-2018-1002209
DescriptionQuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs902786

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libquazip (PTS)stretch0.7.2-1vulnerable
buster0.7.6-2fixed
bullseye, sid0.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libquazipsource(unstable)0.7.6-1902786

Notes

[stretch] - libquazip <no-dsa> (Minor issue)
[jessie] - libquazip <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1593011

Search for package or bug name: Reporting problems