CVE-2018-10100

NameCVE-2018-10100
DescriptionBefore WordPress 4.9.5, the redirection URL for the login page was not validated or sanitized if forced to use HTTPS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1366-1, DSA-4193-1
NVD severitymedium (attack range: remote)
Debian Bugs895034

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch4.7.5+dfsg-2+deb9u3fixed
stretch (security)4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.7+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.5+dfsg1-1medium895034
wordpresssourcejessie4.1+dfsg-1+deb8u17mediumDSA-4193-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u3mediumDSA-4193-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u21mediumDLA-1366-1

Notes

https://core.trac.wordpress.org/changeset/42892
https://github.com/WordPress/WordPress/commit/14bc2c0a6fde0da04b47130707e01df850eedc7e

Search for package or bug name: Reporting problems