CVE-2018-1064

NameCVE-2018-1064
Descriptionlibvirt version before 4.2.0-rc1 is vulnerable to a resource exhaustion as a result of an incomplete fix for CVE-2018-5748 that affects QEMU monitor but now also triggered via QEMU guest agent.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1315-1, DSA-4137-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)jessie (security), jessie1.2.9-9+deb8u5fixed
stretch (security), stretch3.0.0-4+deb9u3fixed
buster, sid4.7.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)4.1.0-1medium
libvirtsourcejessie1.2.9-9+deb8u5mediumDSA-4137-1
libvirtsourcestretch3.0.0-4+deb9u3mediumDSA-4137-1
libvirtsourcewheezy0.9.12.3-1+deb7u3mediumDLA-1315-1

Notes

Fixed by: https://libvirt.org/git/?p=libvirt.git;a=commit;h=fbf31e1a4cd19d6f6e33e0937a009775cd7d9513

Search for package or bug name: Reporting problems