CVE-2018-1071

NameCVE-2018-1071
Descriptionzsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1335-1
NVD severitylow
Debian Bugs894044

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie5.0.7-5vulnerable
jessie (security)5.0.7-5+deb8u1vulnerable
stretch5.3.1-4vulnerable
buster5.7.1-1fixed
bullseye, sid5.8-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.4.2-4low894044
zshsourcewheezy4.3.17-1+deb7u2DLA-1335-1

Notes

[stretch] - zsh <no-dsa> (Minor issue)
[jessie] - zsh <no-dsa> (Minor issue)
https://sourceforge.net/p/zsh/code/ci/679b71ec4d852037fe5f73d35bf557b0f406c8d4
https://bugzilla.redhat.com/show_bug.cgi?id=1553531

Search for package or bug name: Reporting problems