CVE-2018-10767

NameCVE-2018-10767
DescriptionThere is a stack-based buffer over-read in calling GLib in the function gxps_images_guess_content_type of gxps-images.c in libgxps through 0.3.0 because it does not reject negative return values from a g_input_stream_read call. A crafted input will lead to a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs898133

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgxps (PTS)jessie0.2.2-3vulnerable
stretch0.2.4-1vulnerable
buster, sid0.3.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgxpssource(unstable)(unfixed)medium898133

Notes

[stretch] - libgxps <no-dsa> (Minor issue)
[jessie] - libgxps <no-dsa> (Minor issue)
[wheezy] - libgxps <ignored> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1575188

Search for package or bug name: Reporting problems