|Description||Zsh before version 5.4.2-test-1 is vulnerable to a buffer overflow in the shell autocomplete functionality. A local unprivileged user can create a specially crafted directory path which leads to code execution in the context of the user who tries to use autocomplete to traverse the before mentioned path. If the user affected is privileged, this leads to privilege escalation.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)|
Vulnerable and fixed packages
The table below lists information on source packages.
|zsh (PTS)||buster, buster (security)||5.7.1-1+deb10u1||fixed|
|bullseye (security), bullseye||5.8-6+deb11u1||fixed|
The information below is based on the following data on fixed versions.
[jessie] - zsh <no-dsa> (Minor issue)