CVE-2018-1084

NameCVE-2018-1084
Descriptioncorosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4174-1
NVD severityhigh (attack range: remote)
Debian Bugs895653

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
corosync (PTS)jessie1.4.6-1.1fixed
stretch (security), stretch2.4.2-3+deb9u1fixed
buster, sid2.4.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
corosyncsource(unstable)2.4.4-1high895653
corosyncsourcejessie(not affected)
corosyncsourcestretch2.4.2-3+deb9u1highDSA-4174-1
corosyncsourcewheezy(not affected)

Notes

[jessie] - corosync <not-affected> (Vulnerable code introduced later)
[wheezy] - corosync <not-affected> (Vulnerable code introduced later)
http://www.openwall.com/lists/oss-security/2018/04/12/2
https://bugzilla.redhat.com/show_bug.cgi?id=1552830
Fixed by: https://github.com/corosync/corosync/commit/fc1d5418533c1faf21616b282c2559bed7d361c4
https://oss.clusterlabs.org/pipermail/users/2018-April/014856.html

Search for package or bug name: Reporting problems