CVE-2018-1086

NameCVE-2018-1086
Descriptionpcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4169-1
Debian Bugs895313

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcs (PTS)stretch0.9.155+dfsg-2vulnerable
stretch (security)0.9.155+dfsg-2+deb9u1fixed
buster, sid0.9.164-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcssource(unstable)0.9.164-1895313
pcssourcestretch0.9.155+dfsg-2+deb9u1DSA-4169-1

Notes

http://www.openwall.com/lists/oss-security/2018/04/09/2

Search for package or bug name: Reporting problems