CVE-2018-10873

NameCVE-2018-10873
DescriptionA vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1486-1, DLA-1489-1, DSA-4319-1
NVD severitymedium
Debian Bugs906315, 906316

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice (PTS)jessie0.12.5-1+deb8u5vulnerable
jessie (security)0.12.5-1+deb8u7fixed
stretch (security), stretch0.12.8-2.1+deb9u3fixed
buster0.14.0-1.3fixed
bullseye, sid0.14.2-4fixed
spice-gtk (PTS)jessie0.25-1vulnerable
jessie (security)0.25-1+deb8u1fixed
stretch0.33-3.3+deb9u1vulnerable
buster0.35-2fixed
bullseye, sid0.37-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spicesource(unstable)0.14.0-1.1906315
spicesourcejessie0.12.5-1+deb8u6DLA-1486-1
spicesourcestretch0.12.8-2.1+deb9u2DSA-4319-1
spice-gtksource(unstable)0.35-1906316
spice-gtksourcejessie0.25-1+deb8u1DLA-1489-1

Notes

[stretch] - spice-gtk <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/spice/spice-common/commit/bb15d4815ab586b4c4a20f4a565970a44824c42c

Search for package or bug name: Reporting problems