|Description||A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)|
|References||DLA-1486-1, DLA-1489-1, DSA-4319-1|
|Debian Bugs||906315, 906316|
Vulnerable and fixed packages
The table below lists information on source packages.
|spice (PTS)||buster, buster (security)||0.14.0-1.3+deb10u1||fixed|
The information below is based on the following data on fixed versions.