CVE-2018-10893

NameCVE-2018-10893
DescriptionMultiple integer overflow and buffer overflow issues were discovered in spice-client's handling of LZ compressed frames. A malicious server could cause the client to crash or, potentially, execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs904161

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice-gtk (PTS)jessie0.25-1vulnerable
jessie (security)0.25-1+deb8u1vulnerable
stretch0.33-3.3+deb9u1vulnerable
buster, sid0.35-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spice-gtksource(unstable)(unfixed)medium904161

Notes

[stretch] - spice-gtk <no-dsa> (Minor issue)
[jessie] - spice-gtk <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1598234
Ongoing patch review: https://lists.freedesktop.org/archives/spice-devel/2018-July/044489.html

Search for package or bug name: Reporting problems