CVE-2018-11129

NameCVE-2018-11129
DescriptionThe header::add_INFO_descriptor function in header.cpp in VCFtools 0.1.15 allows remote attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact via a crafted vcf file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1807-1
Debian Bugs902190

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vcftools (PTS)buster0.1.16-1fixed
bullseye0.1.16-2fixed
bookworm, sid0.1.16-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vcftoolssourcejessie0.1.12+dfsg-1+deb8u1DLA-1807-1
vcftoolssourcestretch0.1.14+dfsg-4+deb9u1
vcftoolssource(unstable)0.1.16-1low902190

Notes

[wheezy] - vcftools <no-dsa> (Minor issue)
http://seclists.org/fulldisclosure/2018/May/43
https://github.com/vcftools/vcftools/issues/109

Search for package or bug name: Reporting problems