CVE-2018-1123

NameCVE-2018-1123
Descriptionprocps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the end of the overflowed buffer, ensuring that the impact of this flaw is limited to a crash (temporary denial of service).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1390-1, DSA-4208-1
NVD severitymedium
Debian Bugs899170

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
procps (PTS)jessie (security), jessie2:3.3.9-9+deb8u1fixed
stretch (security), stretch2:3.3.12-3+deb9u1fixed
bullseye, sid, buster2:3.3.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
procpssource(unstable)2:3.3.15-1899170
procpssourcejessie2:3.3.9-9+deb8u1DSA-4208-1
procpssourcestretch2:3.3.12-3+deb9u1DSA-4208-1
procpssourcewheezy1:3.3.3-3+deb7u1DLA-1390-1

Notes

http://www.openwall.com/lists/oss-security/2018/05/17/1
https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
Patch: 0054-ps-output.c-Fix-outbuf-overflows-in-pr_args-etc.patch
https://gitlab.com/procps-ng/procps/commit/136e3724952827bbae8887a42d9d2b6f658a48ab

Search for package or bug name: Reporting problems