CVE-2018-11235

NameCVE-2018-11235
DescriptionIn Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs "git clone --recurse-submodules" because submodule "names" are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with "../" in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4212-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)jessie1:2.1.4-2.1+deb8u6fixed
jessie (security)1:2.1.4-2.1+deb8u7fixed
stretch (security), stretch1:2.11.0-3+deb9u4fixed
buster, sid1:2.19.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:2.17.1-1medium
gitsourcejessie1:2.1.4-2.1+deb8u6mediumDSA-4212-1
gitsourcestretch1:2.11.0-3+deb9u3mediumDSA-4212-1

Notes

https://lkml.org/lkml/2018/5/29/889

Search for package or bug name: Reporting problems