CVE-2018-1124

NameCVE-2018-1124
Descriptionprocps-ng before version 3.3.15 is vulnerable to multiple integer overflows leading to a heap corruption in file2strvec function. This allows a privilege escalation for a local attacker who can create entries in procfs by starting processes, which could result in crashes or arbitrary code execution in proc utilities run by other users.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1390-1, DSA-4208-1
NVD severitymedium (attack range: local)
Debian Bugs899170

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
procps (PTS)jessie (security), jessie2:3.3.9-9+deb8u1fixed
stretch (security), stretch2:3.3.12-3+deb9u1fixed
buster, sid2:3.3.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
procpssource(unstable)2:3.3.15-1medium899170
procpssourcejessie2:3.3.9-9+deb8u1mediumDSA-4208-1
procpssourcestretch2:3.3.12-3+deb9u1mediumDSA-4208-1
procpssourcewheezy1:3.3.3-3+deb7u1mediumDLA-1390-1

Notes

http://www.openwall.com/lists/oss-security/2018/05/17/1
https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
Patch: 0074-proc-readproc.c-Fix-bugs-and-overflows-in-file2strve.patch
https://gitlab.com/procps-ng/procps/commit/36c350f07c75aabf747fb833f52a234ae5781b20

Search for package or bug name: Reporting problems