|Description||procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep. This vulnerability is mitigated by FORTIFY, as it involves strncat() to a stack-allocated string. When pgrep is compiled with FORTIFY (as on Red Hat Enterprise Linux and Fedora), the impact is limited to a crash.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
|NVD severity||medium (attack range: remote)|
Vulnerable and fixed packages
The table below lists information on source packages.
|procps (PTS)||jessie (security), jessie||2:3.3.9-9+deb8u1||fixed|
|stretch (security), stretch||2:3.3.12-3+deb9u1||fixed|
|bullseye, sid, buster||2:3.3.15-2||fixed|
The information below is based on the following data on fixed versions.